Skip To Content

Connect to a database

Different methods can be used to access different databases associated with a project. File geodatabases and connections to enterprise databases are stored on the file system. If you connect your project to a folder in which these databases are stored, you will see them in the folder.

If you find a database in a folder, you can browse to the database and use its contents in that location or add the connection directly to your project. Databases added to the project are available under the Databases category in the Catalog pane and the catalog view. You can quickly access the contents of databases in the project without having to browse to the location where they are stored each time you use the items they contain.

It may be important to connect a project to the folder in which a database is stored as well. Some geoprocessing operations produce output that can't be stored in a database. By default, these output items, such as text or XML files, are stored in the folder that contains the database, unless the geoprocessing environment is configured to store these items in a specific location. If the output location isn't available from the project, you can't access or document the output items.

Access a database in a folder

You can see and work with a file geodatabase, an enterprise geodatabase, a SQLite database, or a geopackage from a folder connection as well as any additional files stored in the same location. This may be important if you create files using data in the database and use those files in the project.

  1. Connect to a folder that contains the database you want to use.
  2. In the Catalog pane or the catalog view, browse to the folder that contains the database.
  3. Browse into the database and start using the items it contains.
Tip:

When you are browsing a folder in the catalog view, you can add a database directly to the project by clicking it and clicking Add To Project Add To Project on the Catalog tab on the ribbon, in the Organize group. In the Catalog pane, right-click a database and click Add To Project Add To Project.

Add a database directly to the project

If you want to work directly with the contents of a file geodatabase, enterprise geodatabase, SQLite, or geopackage, and not other items stored in the same location, you can add the database to the project.

If you have a database connection file (.sde) that can be used to access an enterprise database and this is the first time you've connected to the database from this computer, client software for the database may need to be installed before you can connect.

  1. Add an existing database to the project.
    • Open the catalog view and click Project or Databases in the Contents pane. On the Catalog tab on the ribbon, in the Create group, click the Add drop-down arrow and click Add Database Add Database.
    • On the Insert tab, in the Project group, click the Connections drop-down arrow Add Database and click Add Database Add Database.
  2. Browse to and click the file geodatabase, SQLite database, geopackage, or database connection file on the local or network computer.
  3. Click OK.

    The database appears in the Catalog pane and the catalog view in the Databases category Databases.

  4. Browse to the database to start using the items it contains.
Tip:

You can drag a database or database connection from Windows Explorer to the Catalog pane or the catalog view to add it to a project. You can also drag these items from folder connections in the project to the Databases category to add them directly to the project. Drag the items within the Catalog pane, between the Catalog pane and catalog view, or between two catalog views.

Create a new file geodatabase in the project

You can create a new file geodatabase that will be used in the project.

Create a database in your current location

  1. Create a new file geodatabase.
    • Open the catalog view and click Project or Databases in the Contents pane, or browse into a specific folder. On the Catalog tab on the ribbon, in the Create group, click the New menu and click New File Geodatabase New File Geodatabase.
    • In the browse dialog box, click the New Item menu and click New File Geodatabase New File Geodatabase.

    A new file geodatabase Geodatabase is created in the current location with the name New File Geodatabase and is added to the project under the Databases category Databases. The geodatabase name is immediately editable.

  2. Type a name for the file geodatabase.
  3. Press Enter.

    The file geodatabase is updated with the new name.

Create a database in another location

  1. Open the New File Geodatabase dialog box.
    • On the Insert tab, in the Project group, click the Connections drop-down arrow Add Database and click New File Geodatabase New File Geodatabase.
    • Right-click the Databases category Databases in the Catalog pane or catalog view and click New File Geodatabase New File Geodatabase.
  2. Browse to a folder on the local or network computer where the new file geodatabase will be stored.
  3. Type a name for the new file geodatabase in the Name text box.
  4. Click Save.

A file geodatabase Geodatabase is created in the specified location with the provided name and is added to the project. It appears in the Databases category Databases.

Create a new enterprise database connection

Before you can use the contents of an enterprise database in ArcGIS Pro, you must first create a connection that provides access to the database. In most cases, your database or GIS administrator will provide you with the information to configure your local computer and establish a connection to the database. Client software for the database may need to be installed on the local computer before you can connect to the database.

  1. Create a new enterprise database connection.
    • Open the catalog view and click Project or Databases in the Contents pane. On the Catalog tab on the ribbon, in the Create group, click the New drop-down arrow and click New Database Connection New Geodatabase Connection.
    • On the Insert tab, in the Project group, click the Connections drop-down arrow Add Database and click New Database Connection New Geodatabase Connection.
  2. Provide the connection information for accessing the database.
  3. Click OK.

    A database connection Geodatabase Connection is created and stored in the project's home folder with the name of the database instance. The connection appears in the Databases category Databases along with any other databases that have already been added to the project. The database connection file name is immediately editable.

  4. Type a name for the new database connection.
  5. Press Enter.

The database connection is updated with the new name.

Favorite a database

If you add the same database to many projects, favorite that database to simplify the process. The project favorites collection is always available. Add a favorite database to projects without having to remember its location or any connection details. A favorite enterprise geodatabase, for example, can be added to every new project. New file geodatabases and database connections can be created directly in the project favorites folder; if your user profile supports roaming, they will be available and current on every computer you use.

Tip:

You can drag any database or database connection from Windows Explorer to the favorites collection in the Catalog pane or the catalog view. You can also drag these items from the Project tab in the Catalog pane to the favorites collection in the catalog view, or drag them between two catalog views. For database connections, a copy of the connection file will be saved to the project favorites roaming folder.

Related topics