Skip To Content

Navigation

Lorsque vous consultez ou créez des cartes et scènes, vous effectuez des zooms avant et arrière, vous vous déplacez, et dans le cas de scènes, vous vous déplacez vers le bas et le haut, et restez même à un endroit et regardez autour. Aidez-vous des outils de navigation, y compris l’outil Explorer, le navigateur à l’écran et l’outil Aller vers XY, pour effectuer toutes ces tâches. D’autres commandes et méthodes de navigation susceptibles d’améliorer la façon dont vous interagissez avec vos cartes et scènes sont notamment les géosignets, les vues liées, les échelles de la carte (2D) et la hauteur de scène (3D), ainsi que les modes d’interruption et d’actualisation de l’affichage. Ces méthodes ont un impact sur la façon dont vous interagissez avec vos données, comparez vos données et les mises à jour actives ou modifiez la perspective d’affichage. Elles peuvent en outre optimiser la qualité de performance et la façon dont vous parcourez votre affichage SIG. Par exemple, interrompre l’affichage vous permet de vous concentrer sur des mises à jour spécifiques ou d’explorer des données existantes sans être affecté par une actualisation continue lorsque votre projet contient de grands volumes de données.

Les sections ci-dessous expliquent les modalités d’utilisation de chaque outil, commande et méthode de navigation.

outil Explorer

L'outil par défaut pour toutes les cartes et scènes est l’outil ExplorerOutil Explorer. Utilisez-le pour orienter votre carte ou scène ainsi que pour identifier des entités.

Boutons de la souris avec l'outil Explorer

Utilisez les boutons de la souris pour identifier les attributs d’entités via une fenêtre contextuelle, effectuer un zoom avant ou arrière sur votre contenu, le déplacer, le faire pivoter ou l’incliner si vous êtes en mode 3D. Vous pouvez accéder à d'autres modes de navigation, tels que le zoom sur la vue générale de vos données ou le réglage de la vue vers le nord via des commandes ou des raccourcis clavier.

Navigateur à l’écran

Le navigateur à l’écran dispose de nombreuses commandes de navigation de la caméra avec une seule commande dans l’angle inférieur gauche d’une vue. Les commandes explicites de la caméra sont utiles pour naviguer au travers d’un contenu SIG complexe, surtout les scènes en 3D qui sont en sous-sol, dans des bâtiments ou qui contiennent des données lidar. La commande est adaptée à une interaction avec un écran tactile. Sa capacité à tourner autour d’un point cible fait d’elle l’outil idéal pour l’inspection des entités et l’édition 3D. En tant qu'élément passif de la vue, le navigateur indique toujours le nord. Les images ci-dessous représente le navigateur dans un état réduit à l’en-tête uniquement, par rapport à l'état de commande complet pour les vues 2D et 3D.

Navigateur affichant l’en-tête seulement
Navigateur avec toute la commande en 2D
Navigateur avec toute la commande en 3D

Pour afficher ou masquer le navigateur pour une vue, dans l’onglet View (Vue), dans le groupe Navigation, cliquez sur le bouton Navigator (Navigateur) Navigator. Le navigateur peut être dimensionné en glissant la poignée de redimensionnement en haut à droit de la commande.

Dans son mode d’affichage en petit pour l’en-tête, le navigateur montre un indicateur du nord. Vous pouvez vous déplacer sur votre carte ou scène en cliquant et en glissant la bague extérieure. Une flèche partiellement transparente indique le sens de déplacement et la vitesse. Cliquez sur la flèche du nord pour remettre la caméra face au nord.

Dans son mode d’affichage en grand, le navigateur présente d’autres fonctions de navigation de la caméra. En 2D, cela comprend la rotation de la vue, le zoom avant et arrière et le pivotement vers l’est, l’ouest ou le sud. En 3D, cela comprend le sens de vue (seulement), le pivotement autour du point cible sur les trois axes, le zoom avant et arrière sur le point cible, le déplacement de la caméra vers le haut et le bas et un tour d’horizon à partir de la position actuelle de la caméra.

Par défaut, le navigateur est masqué dans les vues en 2D et affiché à son état d’en-tête dans les vues en 3D. Cliquez sur l’onglet Project (Projet), puis sur l’onglet Options. Dans la boîte de dialogue Options, sous l'en-tête Application, cliquez sur l'onglet Navigation. Développez l’en-tête Navigateur à l’écran pour configurer ces options.

Aller vers XY, outil

Un emplacement en entrée vous est parfois fourni, auquel vous devez accéder directement. Vous pouvez saisir les coordonnées x,y dans l’outil Aller vers XY et y accéder directement. Une liste des unités prises en charge permet également de changer le format qui est renvoyé en temps réel.

Afin d’afficher ou de masquer l’outil Aller vers XY, dans l’onglet Map (Carte), dans le groupe Navigate (Naviguer), cliquez sur le bouton Go To XY (Aller vers XY) Aller à XY pour afficher la superposition dans la vue.

Commandes de navigation courantes

L'onglet Carte du groupe Naviguer rassemble un grand nombre d'outils de navigation couramment utilisés : Cliquez sur le bouton de lancement de boîte de dialogue Lanceur pour modifier le comportement de navigation par défaut dans les cartes et les scènes.

Commande de navigationDescription

Explorer Outil Explorer

Outil multifonctionnel pour la navigation et l'identification des entités. Il s'agit de l'outil par défaut lorsque vous ouvrez un projet existant ou nouveau. Les boutons gauche, droit et central de la souris disposent tous de fonctions intégrées comme suit :

  • Clic gauche : identification par fenêtre contextuelle d’une entité
  • Glisser gauche : panoramique
  • Mollette centrale : zoom avant et arrière
  • Clic central et glisser : rotation et inclinaison (3D seulement)
  • Bouton droit enfoncé : zoom continu
  • Clic droit : menu contextuel d’outils supplémentaires

Etendue précédente Etendue précédente

Permet de revenir à l'étendue précédente si elle existe.

Etendue suivante Etendue suivante

Permet d'accéder à l'étendue suivante si elle existe.

Zoom sur la sélection Zoom sur les entités sélectionnées

La vue est centrée et un zoom est appliqué sur l’étendue du jeu sélectionné d'entités.

Un zoom sur une seule entité sélectionnée entraîne un zoom sur l’ensemble de sa géométrie ; toutefois, lorsque vous zoomez sur un seul point sélectionné dans la vue, la vue effectue un zoom avec un pourcentage fixe.

Vue générale Vue générale

Un zoom est appliqué sur la vue générale des données dans la carte.

Géosignets Géosignets

Permet de créer des géosignets ou d’ utiliser des géosignets existants pour accéder aux emplacements. Vous pouvez également ouvrir la fenêtre Bookmarks (Géosignets) pour gérer les géosignets existants en effectuant les actions nécessaires (mise à jour ou suppression, par exemple).

Autres modes de navigation

Vous pouvez également employer les méthodes de navigation décrites ci-dessous.

Commandes de navigation

Dans certains cas, vous pouvez être amené à modifier l'étendue de la carte en fonction d'une action précédente. Par exemple, après avoir sélectionné des entités, vous pouvez zoomer dessus pour les regarder de plus près. Les commandes à partir d'un menu contextuel ou d'un bouton sont différentes de l'expérience interactive dont vous bénéficiez à l'aide de la souris.

Pour naviguer dans la vue à l’aide des boutons et commandes, procédez comme suit :

  • Zoom sur la vue générale de toutes vos données : appuyez sur la touche Inser ou, dans l’onglet Map (Carte), dans le groupe Navigate (Naviguer), cliquez sur Full Extent (Vue générale) Vue générale.
  • Zoom sur l'étendue d'une couche : appuyez sur la touche Alt, puis cliquez sur une couche dans la fenêtre Contenu pour effectuer un zoom sur l'étendue d'une couche.
  • Zoom sur l’étendue de plusieurs couches : appuyez sur la touche Ctrl, sélectionnez les couches dans la fenêtre Contents (Contenu), cliquez avec le bouton droit et choisissez Zoom To Layer (Zoom sur la couche).
  • Zoom sur les entités sélectionnées : utilisez l’outil de géotraitement Sélectionner selon les attributs ou Sélectionner selon l’emplacement et cliquez sur les résultats Selected Features (Entités sélectionnées) au bas de la vue, ou utilisez le menu contextuel de la couche des entités sélectionnées dans la fenêtre Contents (Contenu). Un zoom sur une seule entité sélectionnée entraîne un zoom sur l’ensemble de sa géométrie ; toutefois, lorsque vous zoomez sur un seul point sélectionné dans la vue, la vue effectue un zoom avec un pourcentage fixe.
  • Revenir à un emplacement précédent : créez un jeu de géosignets pour la vue.
  • Cliquez avec le bouton droit sur un résultat de recherche dans la fenêtre Localiser.

Astuce :

Les positions de navigation que vous utilisez sont stockées sous la forme d’étendues auxquelles vous pouvez accéder via une liste. Dans l’onglet Map (Carte), dans le groupe Navigate (Naviguer), cliquez sur le bouton Previous Extent (Étendue précédente) Etendue précédente ou le bouton Next Extent (Étendue suivante) Etendue suivante pour revisiter ces étendues lorsque vous avez arrêté la navigation. Vous pouvez également naviguer vers l’étendue précédente ou suivante en cliquant avec le bouton droit lorsque l’outil Explorer Outil Explorer est actif. Cette liste d’étendues est conservée uniquement tant qu'une vue est ouverte. Les positions sont également effacées une fois l’application fermée, même si une vue est enregistrée ouverte dans un projet.

Interrompre et actualiser l’affichage

Deux boutons importants apparaissent dans l’angle inférieur droit de l’affichage des cartes et scènes afin de contribuer à l’interactivité : Pause Drawing (Mettre le dessin en pause) et Refresh (Actualiser). Lorsqu’une carte comporte un grand volume de données, le chargement du contenu en mémoire et son affichage peuvent prendre du temps. Lorsqu’une carte affiche activement des données, le bouton Refresh (Actualiser) Actualiser commence à tourner. Cliquez sur Refresh (Actualiser) pour annuler le dessin. Les entités qui sont déjà affichées restent, mais aucune autre entité n’est ajoutée à la carte.

Vous pouvez également utiliser le bouton Pause Drawing (Mettre le dessin en pause) Suspendre le dessin pour arrêter temporairement l’affichage de vos cartes et scènes. Lorsque vous cliquez sur ce bouton, la mention Paused (Interruption) apparaît en haut de la vue. Le chargement de données supplémentaires est suspendu jusqu’à sa désactivation. Toutes les fonctionnalités de navigation et de mise à jour sont toujours disponibles pendant cette période. Cela vous permet de modifier le contenu de la carte sans la redessiner. Si vous désactivez la visibilité d’une couche, ou ajoutez une nouvelle couche à la carte, elle n’apparaît pas tant que vous n’avez pas quitté l’état d’interruption du dessin.

Dans le mode Mise en page, l’état d’interruption du dessin s’applique uniquement aux fenêtres cartographiques. Il n’affecte pas les autres éléments dynamiques, tels que les flèches d’orientation vers le nord ou les barres d’échelle.

Géosignets

Les géosignets permettent de stocker des emplacements de vos cartes et scènes pour que vous puissiez revenir à une position particulière, un point dans le temps spécifique ou une valeur de plage de données précise. Il est également possible d’ajouter une propriété de description facultative.

Sur l’onglet Carte, cliquez sur le menu Géosignet pour naviguer à l’aide des géosignets. Cliquez sur le bouton Gérer les géosignets Gérer les Géosignets pour gérer tous vos géosignets à partir de la fenêtre Géosignets.

Vues liées

Lorsque vous souhaitez coordonner la navigation de plusieurs cartes et scènes à la fois, vous pouvez lier les vues. Par défaut, chaque vue fonctionne individuellement, mais vous pouvez les lier afin qu’une vue active déclenche la navigation correspondante dans d’autres vues. Ceci est utile pour afficher plusieurs jeux de données côte à côte sans avoir à activer et désactiver les couches. Vous pouvez examiner plusieurs perspectives, des mises à jour, etc. Une liaison peut être établie pour que les vues reflètent le centre de la vue uniquement ou pour qu'elles reflètent le centre, ainsi que les modifications apportées à la rotation et à l'échelle.

Outils et commandes propres aux vues 2D ou 3D

Même s’il existe de nombreuses similitudes entre la navigation dans des environnements 2D et 3D, il existe des différences importantes.

Echelle 2D

Lorsque vous dessinez une carte, vous pouvez afficher la carte à n’importe quelle échelle. Vous pouvez également configurer une série d’échelles de carte qui vous permettront de sélectionner une échelle de la carte dans une liste. Les échelles sont sélectionnées et saisies dans la liste au bas de l'affichage.

  • L'échelle actuelle et les autres échelles que vous indiquez sont conservées dans une liste pour en faciliter l'accès.
  • Vous pouvez gérer les valeurs d'échelle et les formats à l'aide de la boîte de dialogue Propriétés d'échelle pour mettre au point une liste d'échelles personnalisée.
  • Pour modifier les échelles, choisissez une valeur dans la liste développer afin de zoomer sur les échelles spécifiées.

Pour en savoir plus sur les échelles et la gestion des échelles

Hauteur 3D

Les valeurs de hauteur répertoriées au bas de l'affichage illustrent la hauteur au-dessus du sol. Sur une carte, vous définissez l'échelle de la carte souhaitée, mais dans une scène, vous définissez la hauteur au-dessus du sol souhaitée. Si vous entrez une valeur de 2 mètres en tant que hauteur 3D, le point de vue s’ajuste à 2 mètres au-dessus du sol, que vous soyez dans une chaîne de montagnes ou en bord de mer. La valeur affichée dans la zone de hauteur 3D repose sur la résolution actuelle de l'altitude en cours d'affichage. Sa précision augmente au fur et à mesure que vous approchez du sol.

La valeur du contrôle de la hauteur 3D est différente de la valeur Z de la distance par rapport au pointeur qui est illustrée dans l’affichage du système de coordonnées, également au bas de votre vue. Les valeurs Z représentent l'altitude de l'emplacement actuel du pointeur dans la vue.

Par exemple, dans votre zone d'étude, vous voulez visualiser les montagnes à 100 pieds au-dessus du sol. Saisissez 100 dans la liste de hauteurs. Cette opération place la vue à 100 pieds au-dessus du sol. Pour déterminer l’altitude d’une montagne en particulier, positionnez le pointeur en haut de cette dernière. Observez la valeur Z qui apparaît au bas de l'affichage, avec les coordonnées. Vous obtenez ainsi l'altitude de la montagne.

Remarque :
  • Les valeurs Z n'apparaissent pas par défaut. Dans l’onglet Map (Carte), dans le groupe Navigate (Naviguer), cliquez sur le bouton de lancement de la boîte de dialogue Lanceur pour ouvrir les options de navigation. Dans la boîte de dialogue Options, vous pouvez activer la vue pour afficher la distance par rapport au pointeur.
  • Pour ajouter une nouvelle unité aux unités d’emplacement de projet, cliquez sur l’onglet Projet, puis sur l’onglet Options. Dans la boîte de dialogue Options, cliquez sur l’onglet Unités, puis sur Sélectionner le code unitairedans la dernière ligne du tableau d’une des catégories. Choisissez dans la liste des unités. Cliquez avec le bouton droit sur une unité pour supprimer, formater l’unité ou en faire l’unité par défaut.

Raccourcis clavier 3D

Vous pouvez utiliser les raccourcis suivants pour les vues 3D :

  • Orientation orthogonale : appuyez sur la touche P pour orienter la vue orthogonalement par rapport à la surface (pour regarder tout droit vers le bas, par exemple). Cette opération peut faciliter la navigation si vous devez rétablir la vue sur un emplacement de départ plus courant.
  • Tour d’horizon : appuyez sur la touche B pour que la caméra reste en place pendant que vous utilisez la souris pour faire un tour d’horizon de la vue.

Rubriques connexes