Create Business Analyst custom data

Available with Business Analyst license.

Custom data in Business Analyst allows you to work with your own data in mapping and analysis. Custom data allows you to define how your data is apportioned and aggregated when used with Business Analyst tools—for example, Enrich Layer.

The primary component of custom data is the Statistical Data Collection (SDCX). An .sdcx file is a set of variables that you create from any polygon data source to be used with Business Analyst tools. You can create a Statistical Data Collection from any proprietary, third-party, or Esri-provided data.

Statistical Data Collection

A Statistical Data Collection can be created only if a local Business Analyst dataset has been installed. Once created, the properties of the Statistical Data Collection variables can be interactively edited, allowing you to control the characteristics of apportionment, weighting, and formatting. For example, you can define a population variable as a percent, or a quarterly sales variable as an average.

In the Data Browser window, you can select your new variables by clicking the Custom Data node. The following geoprocessing tools support custom data SDCX variables:

Dive-in:

To get started creating your own Statistical Data Collection, follow this workflow: Create a Statistical Data Collection.

Create a Statistical Data Collection

The following steps will guide you through the creation of a new Statistical Data Collection.

  1. On the Insert tab, in the Project group, click the Connections drop-down menu Add Database and click New Statistical Data Collection New Statistical Data Collection.

    The Add Data dialog box appears.

  2. Browse to the location of a polygon feature class that will be used to create the Statistical Data Collection.
  3. Click OK.

    Statistical Data Collections Statistical Data Collection Container is added to the Project pane, containing the new Statistical Data Collection.

  4. Right-click the new Statistical Data Collection and click Edit.

    The Statistical Data Collection editor dialog box appears.

  5. Click Variables and uncheck the fields that are not useful for enriching data. Set the Summary Type, Weight, Apportionment Method, and Type for the remaining fields.
  6. Click Properties and fill in the available fields.
  7. Click OK.

Usage notes

  • A Statistical Data Collection is a file that stores the path to a source dataset and other custom data properties.
  • The .sdcx file is stored in the project home folder.
  • The .sdcx file is linked to the active Business Analyst dataset and references its data for apportionment and aggregation.
  • If no version of the Business Analyst dataset is installed or available, the .sdcx file becomes inactive.
  • If the active Business Analyst dataset—used to create the .sdcx file—is uninstalled or becomes unavailable, an attempt will be made to update to another version of the same country dataset.
  • The list of available apportionment methods can vary based on the data source. The default list of these weight fields is referenced from the census block centroid point layer.

Create calculated variables in Statistical Data Collections

Calculated variables are new fields you can add to a Statistical Data Collection to build custom expressions for analysis. Custom expressions can include simple calculations, complex Python code, or combinations of two or more existing fields. You can import or export calculated variables as a label expression file (LXP).

Learn about the fundamentals of field calculations

The following steps describe how to create and edit a calculated variable in a Statistical Data Collection:

  1. Start ArcGIS Pro and open the Catalog pane, if necessary.
    Tip:

    To open the Catalog pane, click the View tab on the ribbon and click the Catalog button Catalog Pane.

  2. Under the Project tab, right-click the Statistical Data Collection and click Edit.

    The Statistical Data Collection editor appears.

  3. Click Add to create a calculated variable.

    The Calculate Variable dialog box appears.

  4. Build your calculation in the Expression box. Here you can combine fields, insert values, import scripts, or write your own custom expression.
  5. Click Verify Verify to verify the expression.
  6. In the Name text box, enter the field name.
  7. In the Title text box, enter the alias.
  8. When finished, click OK.

    The new Calculated Variable field is added to your Statistical Data Collection.

    • To modify any of the field properties, such as Vintage, Field Format, or Category, right-click the field and click Properties.
    • To edit your calculated variable, select the field and click Edit Calculation or right-click the field and click Edit Calculation.
    • To permanently remove your Calculated Variable, select the field and click Delete.

SDCX Indexes

You can create Statistical Data Collections with indexes to improve the performance of analysis. By default, locally installed Business Analyst datasets and online data are indexed. When using custom data, building an index is recommended for best performance. The Statistical Data Collection editor dialog box is a convenient way to update and manage performance indexes associated with custom data.

You can create and rebuild an SDCX index from the Statistical Data Collection editor dialog box, on the Source tab, or from the Generate SDCX Index geoprocessing tool. If any modification is made to the SDCX file, such as changing the apportionment layer or changing a weight value, these changes are automatically detected and the index should be rebuilt.

Usage notes

Statistical Data Collection (SDCX) files can contain references to standard Esri data variables for use in geoprocessing tools, such as Enrich Layer.

  • Standard variables are added using the Add Variable command in the Statistical Data Collection Editor.
  • Adding a standard variable acts as a reference to the underlying variable in the active Business Analyst dataset.
  • Added standard variables are not hard-coded; for example, an added variable will reference the current year of the active Business Analyst dataset. If you switch to the previous year's dataset, the variable reference will automatically update to reference that year.
  • You can add any standard variable accessible from the Data Browser window to the SDCX file.
  • Variables from other SDCX files are not supported.
  • Added standard variable aliases are supported in the Data Browser window and tool output—for example, 2022 Total Population. Field names are used in the SDCX Variables view—for example, populationtotals.TOTPOP_CY.
  • Online data variables are not supported.
  • Standard variables are not supported when sharing an SDCX. These variables will be removed when shared.

ArcMap BDS layers

BDS files are a type of custom data that is created with Business Analyst for ArcGIS Desktop. BDS layers are also available under the Custom Data node in the Data Browser window if local data is selected as the data source.

Related topics