Skip To Content

Transform features

In the Modify Features pane, Transform Transform includes Affine and Similarity methods for transforming features. You can transform features that are visible and editable by selecting them or transform all features on specified layers.

Two-point displacement links define the origin and target location of the features you are transforming. Affine transformations require three or more links. Similarity transformations require two or more links.

The result is a best-fit transformation between the links. The amount of distortion made to the shape, area, distance or direction of your data depends on the transformation method you choose to apply and the number and location of the displacements links you create.

Transformations

Note:

Projective transformations are commonly used to transform data captured directly from aerial photography, and require four or more links.

To apply a projective transformation, use the Transform Features geoprocessing tool.

Perform an Affine or Similarity transformation

  1. On the Edit tab, in the Snapping group, enable your snapping preferences.
    Tip:

    You can press and hold the spacebar to temporarily turn off snapping as you create displacement links.

  2. On the Edit tab, in the Features group, click Modify Modify Features.

    The Modify Features pane appears.

  3. Expand Alignment and click Transform Transform.

    The tool opens in the pane.

  4. Select the features you want to transform using one of the following methods:
    • Click the Selected feature tab, and use Active Select Active Select to select the feature you want to transform.
      Note:

      To refine your selection, right-click a feature in the pane and use the commands on the context menu.

      Selection context menu

    • Click the Layer tab and choose the layer on which the features reside. This method transforms all features on the selected layer.
  5. Click the Transformation Method drop-down arrow and choose an transformation method.
    • Affine—Requires a minimum of three links. Features are differentially scaled, rotated, translated, reflected, and skewed. Angles and lengths are not preserved. Straight lines and ratios between distances along a straight line are preserved, and parallel lines remain parallel.
    • Similarity—Requires a minimum of two links. Features are scaled uniformly, rotated, translated, and reflected. Straight lines and ratios between distances along a straight line remain unchanged, and parallel lines remain parallel.
      Note:

      The relative shape of the feature is preserved, making this a good choice for CAD drawings and other file-based data that should not be skewed.

  6. Draw a suitable number of two-point displacement links that define the origin and target location for the features you are transforming. When you draw the minimum required links, the root mean square (RMS) error displays at the top of the pane. There is no limit to the number of links you can draw.
    1. Click Add new links Add New Link.

      The segment construction toolbar appears at the bottom of the map.

      Segment construction toolbar
    2. Snap and click the origin point to an edge or a vertex on the feature you are transforming.
    3. Snap and click the endpoint to the new target location.
    Tip:

    You can save time from drawing links by clicking Load links from file Browse and loading predefined links contained in a link file created with ArcMap. Link files are TAB delimited ASCII text files containing two pairs of XY coordinate values per row for each link.

    You can load four-column or five-column link files. A four-column link file contains a pair of source and destination coordinate values. A five-column link file contains an ID column (string or numeric) that precedes the columns containing the coordinate values.

    Example contents for a five-column link file.

    3	1032507.603691	1865947.186470	1032507.207115	1865926.170407
    
    2	1032508.350801	1865986.785187	1032509.079486	1866025.405116
    
    1	1032388.666424	1865961.179459	1032361.009572	1865981.280533

  7. To delete a displacement link, do the following:
    • Click Select Select, select the link and press the Delete key or right-click and click Delete on the context menu.
    • To delete all displacement links, in the pane, click Delete all links Delete.
  8. Click Transform.

    The features transform, and the displacement links are automatically deleted.

The RMS error

The RMS error reports the overall fitness of the transformation based on the number and location of your displacement links. Each link generates a residual error that measures the fit between the location of the destination control point and the actual transformed location.

Residual errors

The RMS error shown in the pane is the calculated sum of the residual errors generated by each link using the following formula.

RMS equation

RMS errors vary depending on the accuracy of the original data and the scale of the source map. In some cases, a high RMS error can indicate a large amount of stretching or skewing of your data will occur.

Your particular requirements ultimately determine what an acceptable RMS error is. When an RMS error is determined to be too high, you can adjust the error by removing links and adding new control points.

Transformation equations

Affine

x’ = Ax + By + C
y’ = Dx + Ey + F

where:

A = Sx cos rB = (Sy / cos s) sin(s - r)
C = DxD = Sx sin rE = (Sy / cos s) cos(s - r)
F = DySx, Sy = Scaling factors (can be negative)
Dx, Dy = Translation distances in x and y directions (can be negative)
s = Skew angle of shearing along x-axis, measured from y-axis (-pi/2 < s < pi/2)
r = Rotation angle in radians, measured counterclockwise from x-axis (- pi < r <= pi)

Similarity

x' = Ax + By + C 
y' = -Bx + Ay + F

where:

A = s * cos tB = s * sin tC = Translation in x direction
F = Translation in y direction
s = Scale change (same in x and y directions)
t = Rotation angle, measured counterclockwise from the x-axis

Projective

x' = (Ax + By + C) / (Gx + Hy + 1)
y' = (Dx + Ey + F) / (Gx + Hy + 1)